[dns-operations] Single label queries on Windows (11)

Viktor Dukhovni ietf-dane at dukhovni.org
Fri Jul 7 18:32:29 UTC 2023

On Fri, Jul 07, 2023 at 08:09:39PM +0200, Petr Menšík wrote:

> I have tested recently how Windows 11 behaves when resolving single 
> label queries.
> I have expected it might try to use LLMNR. But I did not expect it would 
> do so also when trying nslookup, a tool which should be DNS only tool.
> I have tried:
> nslookup -type=ns com

It is not too surprising if this is also subject to the default suffix
list of the network "connection", which initialises the resolution
context, and then just overrides the server.  Have you tried:

    nslookup -type=ns com.

with an explicit trailing "."?

> Got NXDOMAIN. I were very suprised, learned that does not exist. Even 
> more suprising were fact, that it presented the result came from the 
> specified server.

But the result should have been for "com.<your-default-suffix>."
What happens when you configure the network connection with a default
suffix of "."?


More information about the dns-operations mailing list