[dns-operations] Single label queries on Windows (11)

Petr Menšík pemensik at redhat.com
Fri Jul 7 18:09:39 UTC 2023


I have tested recently how Windows 11 behaves when resolving single 
label queries.

I have expected it might try to use LLMNR. But I did not expect it would 
do so also when trying nslookup, a tool which should be DNS only tool.

I have tried:

nslookup -type=ns com

Got NXDOMAIN. I were very suprised, learned that does not exist. Even 
more suprising were fact, that it presented the result came from the 
specified server. I am quite certain that server can resolve it 
successfully. When I run the same command on my Linux system, it works 
as it should.

nslookup -type=ns microsoft.com

Of course works as expected.

I would like to file some kind of bug. But have no idea how that could 
be done for Windows (desktop). Is there any bug tracker or at least 
documentation, why it does behave this way? Would you know a good 
contact to anyone from Microsoft, who may I contact? Is this behavior 
considered correct?

Thanks in advance!


Petr Menšík
Software Engineer, RHEL
Red Hat, https://www.redhat.com/
PGP: DFCF908DB7C87E8E529925BC4931CA5B6C9FC5CB

More information about the dns-operations mailing list